存储PLCNext社区 LinkedIn上的PLCNEXT.  Instagram上的PLCNEXT.    youtube上的plcnext. github plcnext社区存储PLCNext社区

  1. atroyas@phoenixcontact.es.
  2. PLCNEXT技术和PLCNEXT控件
  3. 2020年2月6日星期四

你好。

我正在尝试中华彩票彩网pip3 opcua包。

我使用命令

/ opt / local / bin / pip3中华彩票彩网OPCUA。

但它似乎失败了libxml2和libxslt依赖关系。 (附件包含错误)

编辑:我已使用命令中华彩票彩网了libxml2和libxslt依赖关系

ipkg中华彩票彩网libxml2.

ipkg中华彩票彩网libxslt.

但它没有解决这个问题。

我该如何解决?

此致,

天使

2020 02 06 12 04 28 Admin192.168.2.200

Jan.Mueller@PhoenixContact.de. 接受答案 等待审核
0
Votes
撤消

你好,  

 

FW 2020.6也许是替代方案? Python Docker Image包含所有必需的依赖项或可以编译。您必须将程序中华彩票彩网到容器中。

 

G 1月  

dinosilva95 接受答案 等待审核
0
Votes
撤消

你好@song yantao,

我也有一个同样的问题 atroyas@phoenixcontact.es.。错误是确保已中华彩票彩网libxml2和libxslt的开发包。

在这个问题上有任何要求吗? (我们正在使用PLC的2020.6.1版本)。

 

谢谢你的支持。

迪诺  

罗德里戈

     

 

 

 

Song Yantao 接受答案 等待审核
0
Votes
撤消

亲爱的弗兰克和天使,


谢谢你真诚的担忧。我们身体健康,但我们必须这些天待在家里。 

后来我将分享2019年的Numpy鸡蛋.9,你可以先尝试一下,只是分享我的电子邮件。

如何交叉编译它们并不容易,这花了很多时间,所以票据也会花一些时间,但是当它完成后,我认为人们遵循它可以用c编译大多数python软件包

 

@天使

如果你现在真的需要OPCUA 2020.0,请告诉我,我会花时间去做。

<p><a href="mailto:songyantao@phoenixcontact.com.cn..">songyantao@phoenixcontact.com.cn.</a></p>
<p>智能技术应用工程师 - Phoenix联系人(中国)</p>
atroyas@phoenixcontact.es. 接受答案 等待审核
0
Votes
撤消

你好jong,

感谢您的帮助!

我会尝试一下并在这里提供反馈意见。

谢谢你@frank。

此致

天使

Frank PLCnext Team 接受答案 等待审核
0
Votes
撤消

嗨歌,

伟大的描述,我将在下天穿过这些步骤。

如果您可以分享您的知识如何编译Numpy,也会很好。
我刚刚从Python开始,那些提示和技巧受到高度赞赏。

但最重要的是,你们在那边保持健康?

坦率

Phoenix联系电子总部 - PLCNEXT运行时产品管理和支持
Song Yantao 接受答案 等待审核
0
Votes
撤消

README.PDF.

 

上传* .rar文件在此博客中有限,我会向您发送一封电子邮件

<p><a href="mailto:songyantao@phoenixcontact.com.cn..">songyantao@phoenixcontact.com.cn.</a></p>
<p>智能技术应用工程师 - Phoenix联系人(中国)</p>
Song Yantao 接受答案 等待审核
0
Votes
撤消

嗨〜

这些天我也在这一天工作,我只在10分钟前锻炼身体。

迫不及待地想先告诉你!

 

正如弗兰克所说,他们要跨越

我用SDK跨越LXML + Clyptograph + CFFI 2019.9

然后'pip中华彩票彩网opcua'可以成功(只有lxml只有lxml对此步骤)

 

交叉编译的过程真的很复杂,也许下个月我会写一些注释(也是Numpy和Cython)(我本月没有时间,希望你知道现在正在发生的事情)

稍后我将分享只能在2019.9上工作的“蛋”文件。如果您需要其他版本,您可以自己制作 

 

这是一个简单的测试:

 

1

 

 

<p><a href="mailto:songyantao@phoenixcontact.com.cn..">songyantao@phoenixcontact.com.cn.</a></p>
<p>智能技术应用工程师 - Phoenix联系人(中国)</p>
Frank PLCnext Team 接受答案 等待审核
0
Votes
撤消

嗨天使,

我没有时间直接尝试一下,但我想你正在使用的Python包是用C的(如许多其他人,如Numpy)。
在这种情况下,他们与我们的ARM32HF SDK兼容,如果他们没有被跨筹码。

我将在下周的中期度过一点时间来测试这个......

坦率

Phoenix联系电子总部 - PLCNEXT运行时产品管理和支持
  • 页 :
  • 1


这篇文章没有答复。
但是,您不允许回复此帖。